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Introducing the DPS310/368 Kit2Go
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Summary of features

Compatible with Arduino IDE - Fast and easy access to measurement 
results

On-board DPS310/368:
− Pressure operation range: 300 –1200 hPa. 
− Temperature operation range: -40 – 85 °C. 
− Pressure sensor precision: ± 0.002 hPa (or ±0.02 m)
− Temperature accuracy: ± 0.5°C
− DPS368 is IPx8 certified: Temporary immersion of 50m for 1 hour

XMC1100 (ARM® Cortex™-M0 based)

On-board J-Link Lite Debugger
– Realized with XMC4200 Microcontroller

Power over Micro-USB (Plug&Play)
Sensor measurements available through I²C or SPI interface
ESD and reverse current protection
2x User LEDs
Pin Header 1x9 and 1x8 (Shield2Go form factor)
Pin out on top (head) is directly connected to the pins of the DPS

Breakable head for individual sensor usage
− After breaking, head and MCU/Debugger Peripherals can still be used 

independently

Standard delivery interface mode is I²C



Introduction

The DPS310/368 is a miniaturized digital barometric air pressure 
sensor with ultra-high precision (±2 cm) and a low current 
consumption, capable of measuring both pressure and temperature

Due to the robust package of the DPS368, it can withstand harsh 
environments e.g. 50 m under water for one hour (IPx8)

Both pressure sensor elements are based on a capacitive sensing 
principle which guarantees high precision during temperature 
changes. The small package makes the DPS310/368 ideal for 
mobile applications and wearable devices

The internal signal processor converts the output from the pressure 
and temperature sensor elements to 24 bit results. Each unit is 
individually calibrated and the calibration coefficients calculated 
during this process are stored in the calibration registers. The 
coefficients are used in the application to convert the measurement 
results to high accuracy pressure and temperature values 

The result FIFO can store up to 32 measurement results, allowing 
for a reduced host processor polling rate. Temperature and 
Pressure measurement results are readable through the serial I2C 
or SPI interface making it easily and quickly accessible by e.g. 
Arduino IDE or Platform.IO with Arduino Extension
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Link to Datasheet and Product Page

Link to Datasheet and Product Page

https://www.infineon.com/dgdl/Infineon-DPS368-DataSheet-v01_01-EN.pdf?fileId=5546d46269e1c019016a0c45105d4b40
https://www.infineon.com/cms/en/product/sensor/pressure-sensors/pressure-sensors-for-iot/dps368/
https://www.infineon.com/dgdl/Infineon-DPS310-DS-v01_00-EN.pdf?fileId=5546d462576f34750157750826c42242
https://www.infineon.com/cms/en/product/sensor/pressure-sensors/pressure-sensors-for-iot/dps310/


Board Information
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MAKE SURE THAT NO VOLTAGE 

APPLIED TO ANY OF THE PINS 

EXCEEDS THE ABSOLUTE 

MAXIMUM RATING OF 4 V

XMC2Go

DPS310/368

Breakble 

Head

I²C/SPI Switch

Connect the Micro-USB to your PC to power up the Kit2Go. PWR LED 
turns green indicating proper power supply

Micro-USB delivers 5 V to power-up the Kit2Go. When breaking the board 
apply no more than 3.3 V to the DPS

Pin out on the bottom (HEAD) is directly connected to the pins of the 
DPS310/368 

If the head is broken off:
− Two capacitors are connected to the DPS310/368 
− MCU and Debugger can still be used

To use the I²C mode, place a pull-up resistors on the lines between 
VDDIO-SDI and VDDIO-SCK (max. 10kΩ each)

− Debugger can also be accessed via SV1

Software compatible with Arduino and library fully integrated into the 
Arduino IDE with help of Infineon’s GitHub page.

Standard delivery of the board (in terms of interface mode) is I²C with 
Address 0x77 when the 0 Ohm resistors are soldered as shown on the 
right picture

Sales Name: KIT_DPS310_2GO and KIT_DPS368_2GO

https://github.com/Infineon/XMC-for-Arduino


Kit2Go PCB Details
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or



Board Schematic (XMC2Go related)
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The Infineon DC-DC converter transforms the 5 V of the 

Micro-USB to 3.3 V for the MCU, Debugger and 

Peripherals circuits

The green PWR LED indicates a proper power supply for 

the Kit2GO

The 2 green User-LEDs (LED1 -> P1.0 and LED2 ->P1.1) 

might be configured separately by pulling-up the according 

GPIOs 



DPS310/368

DPS310/368

Board Schematic (DPS310/368 related)
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Default Mode (0Ω-Resistors R11,R12,R13 and R14 soldered):     

I²C with optional interrupt

Secondary Mode (0Ω-Resistors R21,R22,R23 and R24 soldered): 

SPI 4-Wire

J1 Jumper: If soldered, enables the pull-down resistor on the 

interrupt pin and changes the I²C address from 0x77 to 0x76

J2 Jumper: If soldered, connects the INT/GPIO3 pin

Circuit, if the head 

is broken off



Arduino: The Arduino IDE
Arduino is a hardware-software prototyping 
environment IDE developed by arduino.cc:

– Installation Details for Windows:
Click here

– Installation Details for Linux:
Click here

– Installation Details for Mac OS:
Click here

– Installation Details for Portable IDE:
Click here
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Arduino Quick Start
− What is Arduino? Click here

− Extended information about the Arduino environment. 

Click here

− How to import libraries? Click here

− How to install additional boards? Click here

− Problems related to Arduino? Click here for troubleshooting

https://www.arduino.cc/en/Guide/Windows
https://www.arduino.cc/en/Guide/Linux
https://www.arduino.cc/en/Guide/MacOSX
https://www.arduino.cc/en/Guide/PortableIDE
https://www.arduino.cc/en/Guide/Introduction
https://www.arduino.cc/en/Guide/Environment
https://www.arduino.cc/en/Guide/Libraries
https://www.arduino.cc/en/Guide/Cores
https://www.arduino.cc/en/Guide/Troubleshooting


SEGGER J-Link

In order to use and program the Infineon XMC 
microcontroller in the Arduino IDE, SEGGER J-Link must 
be installed on your PC 

Please follow this link to SEGGER J-Link and install the J-
Link Software and Documentation Pack for your operating 
system

The XMC-for-Arduino installs the XMC Flasher tool used 
to flash the compiled firmware (.hex) into the XMC device,
which requires Java(TM) SE Runtime Environment to 
be installed in the host system. Click here to download.

Open the Arduino IDE

Navigate to File=>Preferences

Paste the following URL into the 'Additional Boards 
Manager URLs' input field: 
https://github.com/Infineon/Assets/releases/downloa
d/current/package_infineon_index.json
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https://www.segger.com/downloads/jlink
https://www.java.com/en/download/


Setup Arduino IDE - Board
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Open the Arduino IDE

Navigate to Tools=>Board=>Boards Manager...

Type in “xmc“ and install Infineon‘s XMC Microcontroller 

Boards

After installation navigate to Tools=>Board=>XMC Family and 

select XMC1100 XMC2Go



Setup Arduino IDE - Library
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For the DPS368:

Visit our GitHub Repository and download the library as a .zip file

Navigate to Sketch=>Include Library=>Add .ZIP Library... and add the 

recently installed library

Note

Regularly check your installed libraries for updates

In case of problems, please visit the corresponding GitHub Repository 

and open an issue to get further help

For the DPS310:

Navigate to Sketch=>Include Library=>Manage Libraries...

Type “dps“ in the search bar

Install “DigitalPressureSensor“ by Infineon Technologies

Alternative:

Visit our GitHub Repository and download the library as a .zip file

Navigate to Sketch=>Include Library=>Add .ZIP Library... and add the 

recently installed library

https://github.com/Infineon/DPS368-Library-Arduino
https://github.com/Infineon/DPS310-Pressure-Sensor


Example with DPS368 Kit2Go

Connect the DPS368 Kit2Go to your Computer via 

Micro-USB

After having installed the DPS368 library and the 

XMC Family boards, navigate to File=>Examples

Pick the example you like (depending on your I²C/SPI 

configuration) and click on the upload Button (make 

sure Board is XMC1100 XMC2Go)

Select the related COM port from Tools=>Port and 

open the serial monitor with the set baud rate (see 

sketch/code with Serial.begin(<baud rate>);)
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Serial 

Monitor

Follow the same steps for the DPS310 Kit2Go



Important Warning
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Again, the DPS310/368 has a 

maximum rating of 4 V

Third party boards with 5 V logic, e.g. 

the Arduino Uno, cannot be 

connected to the DPS310/368 

Kit2Go board directly, even if the 

power is connected to the 3.3 V pin 

as the interface lines, e.g. SDA/SCL, 

will still be driven by 5 V 

Please use appropriate level shifting 

for these boards

NOT 

POSSIBLE

POSSIBLE

LEVEL SHIFTER

5 V -> 3.3 V
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SCL

SDA

I2C
I2C_SDA

I2C_SCL

INT/GPIO3

CS_N

MISO

MOSI

SCK

SPI

SPI_MISO

SPI_MOSI

SPI_CS_N

SPI_SCK

INT/GPIO3

Default Mode (ZERO Ohm resistors 11,12,13,14 are soldered) - I²C with Interrupt 
(Optional) 
Secondary Mode (ZERO Ohm resistors 21,22,23,24 are soldered) - SPI 4 Wire  

J1 Jumper - Can be soldered to enable the pull-down resistor on the interrupt pin (this 
will also change the address of the sensor from 0x77 to 0x76)

J2 Jumper - Can be soldered to connect the INT/GPIO3 pin

Solder Jumper 2 Pins

1 2J1

100k/50V/1%
R4

10k/50V/1%
R28

10k/50V/1%
R29

10k/50V/1%
R3

SDI

SDI

SCK

SCK

SDO

SDO

CSB_N

CSB_N

I2C_SDA

I2C_SCL

SPI_MISO

SPI_SCK

SPI_CS_N

INT/GPIO3

Power Supply Decoupling

SPI_MOSI
0R/150V/5%

R21

0R/150V/5%

R12

0R/150V/5%

R13

0R/150V/5%

R14

0R/150V/5%

R22

0R/150V/5%

R23

0R/150V/5%

R24

0R/150V/5%

R11

+3V3

+3V3

+3V3

+3V3 +3V3

VDD

VDDIO

SPI

I2C

Solder Jumper 2 Pins

1 2J2

Connection Ports

SPI/I²C Selection Circuit DPS310

Shield2Go Head

1
2
3
4 8

7
6
5

S2G_2A

SDI
SCK
SDO

CSB_N
VDDIO
VDD

Modular_S2G1_Pinout

P0.6

P0.7

P0.8

P0.9

P2.10

P2.11

INT/GPIO3

SCL

SDA

I2C

I2C
CS_N

MISO

MOSI

SCK

SPI

SPI
P2.10

P2.11
P0.0

P0.9

P0.8

P0.7

P0.6

GND

GND GND GND GND

GND GND

DPS310

GND 1

VDD 8SCK4

CSB_N2

SDI3

SDO5

GND 7

VDDIO 6

0.10u/6.3Vdc
C4

0.10u/6.3Vdc
C5

PIC401 

PIC402 
COC4 

PIC501 

PIC502 
COC5 

PIDPS31001 

PIDPS31002 

PIDPS31003 

PIDPS31004 

PIDPS31005 

PIDPS31006 

PIDPS31007 

PIDPS31008 

CODPS310 

PIJ101 PIJ102 

COJ1 

PIJ201 PIJ202 

COJ2 

PIR301 

PIR302 
COR3 

PIR401 

PIR402 
COR4 

PIR1101 PIR1102 

COR11 

PIR1201 PIR1202 

COR12 

PIR1301 PIR1302 

COR13 

PIR1401 PIR1402 

COR14 

PIR2101 PIR2102 

COR21 

PIR2201 PIR2202 

COR22 

PIR2301 PIR2302 

COR23 

PIR2401 PIR2402 

COR24 

PIR2801 

PIR2802 
COR28 

PIR2901 

PIR2902 
COR29 

PIS2G02A01 

PIS2G02A02 

PIS2G02A03 

PIS2G02A04 

PIS2G02A05 

PIS2G02A06 

PIS2G02A07 

PIS2G02A08 

COS2G02A 

PIDPS31002 
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PIS2G02A07 

NLCSB0N 

PIC401 PIC501 

PIDPS31001 

PIDPS31007 
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PIS2G02A01 

PIS2G02A08 

PIR1202 

PIR2901 
NLI2C0SCL 

NLP2011 

POI2C 

POP2011 

PIR1102 

PIR2801 
NLI2C0SDA 

NLP2010 

POI2C 

POP2010 

PIJ201 
NLINT0GPIO3 

NLP000 

POINT0GPIO3 

PIJ101 

PIR402 

PIJ102 

PIJ202 

PIR1302 

PIR1401 

PIR2302 

NLP006 

NLSPI0MISO 

POP006 

POSPI 

PIR2102 

NLP007 

NLSPI0MOSI 

POP007 

POSPI 

PIR2202 

NLP008 
NLSPI0SCK 

POP008 

POSPI 

PIR301 
PIR2402 

NLP009 

NLSPI0CS0N 

POP009 

POSPI 

PIDPS31004 

PIR1201 PIR2201 

PIS2G02A03 

NLSCK 

PIDPS31003 

PIR1101 PIR2101 

PIS2G02A04 

NLSDI 

PIDPS31005 

PIR1301 PIR2301 

PIS2G02A02 

NLSDO 

PIC402 PIC502 

PIDPS31006 

PIDPS31008 

PIR302 

PIR2802 

PIR2902 

PIS2G02A05 

PIS2G02A06 

NLVDD 

NLVDDIO 

POI2C POI2C0SCL POI2C0SDA 

POINT0GPIO3 

POP006 

POP007 

POP008 

POP009 
POP2010 

POP2011 

POSPI POSPI0CS0N POSPI0MISO POSPI0MOSI POSPI0SCK 
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SCL

SDA

I2C
I2C_SDA

I2C_SCL

INT/GPIO3

CS_N

MISO

MOSI

SCK

SPI

SPI_MISO

SPI_MOSI

SPI_CS_N

SPI_SCK

INT/GPIO3

Default Mode (ZERO Ohm resistors 11,12,13,14 are soldered) - I²C with Interrupt 
(Optional) 
Secondary Mode (ZERO Ohm resistors 21,22,23,24 are soldered) - SPI 4 Wire  

J1 Jumper - Can be soldered to enable the pull-down resistor on the interrupt pin (this 
will also change the address of the sensor from 0x77 to 0x76)

J2 Jumper - Can be soldered to connect the INT/GPIO3 pin

Solder Jumper 2 Pins

1 2J1

100k/50V/1%
R4

10k/50V/1%
R28

10k/50V/1%
R29

10k/50V/1%
R3

SDI

SCK

SDO

CSB_N

I2C_SDA

I2C_SCL

SPI_MISO

SPI_SCK

SPI_CS_N

INT/GPIO3

Power Supply Decoupling

SPI_MOSI
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R21
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R14
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SPI

I2C

Solder Jumper 2 Pins
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Connection Ports

SPI/I²C Selection Circuit DPS368

Shield2Go Head
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P0.9
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SCK4 SDO 5

DPS368
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100nF
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100nF
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SDI
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COR4 
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PIR2201 PIR2202 
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PIR2301 PIR2302 
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PIR2801 

PIR2802 
COR28 

PIR2901 

PIR2902 
COR29 

PIS2G02A01 

PIS2G02A02 

PIS2G02A03 

PIS2G02A04 

PIS2G02A05 
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POP2010 
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NLINT0GPIO3 
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PIJ101 
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PIR1401 
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POSPI 
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POP008 

POSPI 
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On-board Debugger including a UART to USB Bridge

Configure wiggler-P0.5 as USIC_Tx but only active while X-spy function is selected

Configure wiggler-P0.4 as USIC_Rx but only active while X-spy function is selected

SCLKOUT-P1.1

DX0B-P1.4

SPI Slave

SWD_OUT

SWCLK

MOSI

CLK_OUT

MISO

CS_IN

CLK_IN

CS_OUT

SPI Master U0C0

U0C1

DOUT0-P1.5

SELO0-P1.0

DX2A-P2.3

DX1A-P2.4

RXD

TXD

UART2 (DM2)

RXD

TXD

DX0A-P0.4

DOUT0-P0.5

U1C0

TXACTIVE# GPIO-P0.6

RESET# GPIO-P0.3

DEBUG_LED# DEBUG_LED# GPIO-P0.2

TX_ENABLE GPIO-P0.7

SWD DIR GPIO-P1.3

SWD_IN

ADC

AIN P14.9

PULL Select GPIO-P0.8

AUX_LED# GPIO-P0.1

UART

SPD

No RESET Pin

Level Shifter

COM LED

SWV

JTAG

Power Supply

Power Supply : 200-299
Debugging Device : 100-199
Target Device : 1-99

Debug Connection Concept

LEDs

PinHeader XMC1100

Target Device (XMC1100)

XMC 2Go Kit
XMC1100 in VQFN24

For further information and software examples please visit www.infineon.com/xmc-dev
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